
Customisation and production of Badges
Getting started with I-Color System Basic Light
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1. Creating a Badge Model

Application opening window

1.1  Configuration of Badge Format

Click on button 

Enter the name of your badge model then validate 
by clicking on 
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Duplicate Selected 
Badge Model

The Software, by default, is set on credit card format
(CR 80) and badge printing in portrait layout.

Configure the badge model according to your requirements.

You can now change the dimensions of the badge 
(length, height, resolution), the print orientation 
(portrait, landscape) and the back-front mode (if your 
printer does not have a back front module, I-Color 
will suggest that you turn your support over to print 
the back).

Then click on

Printer Configuration

Delete Selected Badge 
Model

Create New Badge
Model

Menu Toolbar

Print Selected
Badge Model

Available badge models
Click here to display 
them

Open list of Available 
Models



Modeller Visual Image

1.2  Designing your Badge Model

Zooming in            and zooming out             are controlled with the buttons at the top right corner of your 
editing window. Click on the buttons as many times as necessary to obtain the view you want.

When you have set up your badge configuration, the software will display a blank badge.

To add a Badge Background, click on this button            a window will open and offer you a varied choice in 
the Color Panel.

1.2.1  Adding a badge background

1.2.1.1  Colour
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You can open the badge editing
window.
Initially, we advise you to zoom out 
from the model for better overall 
rendering.
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Action Toolbar
Essentially 
used to add 
components
to model

Resolution index 
and badge size

Menu Toolbar

Selection 
Properties
Component
modification
menu

List of
components
Component
display 
menu Badge Model
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• Choose the badge background.
• Click on              to finalize the action.

Your badge now has the desired colour.

1.2.1.2  Image

To add an image to the badge background, go to the List of Components Menu.

• Click on Front or Back as needed.

• The Selection Properties Menu appears at the top left. 
Then select the Image tab.

• Click on Import choose your image then confirm.

• The Extend box enables you to cover your badge model 
entirely without taking ratio into account.



1.2.2  Adding image

• Select the image square if it is not 
preselected.

• Then at the top left of your screen, 
adjustments are displayed under the 
title Selection Properties. Several tabs 
are available (Positioning, Image and 
Appearance).

The Positioning tab enables you to define the Left/Top 
Margin, the Width and the Height as well as the 
Rotation of your component through the cursors. You can 
also define these values by hand. 
Remember to increase the Width to avoid cutting off your 
text.

Positioning is also possible using the Mouse,
except for rotation. 
If you want to change the dimensions of the image, drag the 
mouse over one of the corners of the image and a double 
arrow will appear.  Then draw out the geometrical shapes to 
obtain the right proportion.

You can also move your image by holding the left mouse 
button down on this item. A 4 way arrow is displayed above 
the image, enabling you to use the «Drag capability».
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To add an Image, click on this button            a square named «Image» appears on your badge.

The Image tab enables you to import your content from your 
storage location.

Click on this Import button then browse through your direc-
tories to recover your file. Finalize the operation by clicking 
on Open.
Your image then appears in the «Image» visual outline.
The image can be deleted using the Delete button. 
A zone of the image to be preserved can be redefined using 
the Realign button.
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The Appearance tab enables you to select a colour designed 
to fill in a surface that the badge background does not cover. 
In this case, check the Opaque box. 

1.2.3  Adding text

To add text, click on the button             to display a Text field on your badge which can be moved around, in 
the same way as the image.

• To print this field, select the Text element if it is not already selected.
• At the top left of your screen, the adjustments are displayed under the title Selection properties. 
      You can choose between several tabs (Positioning, Fund, Text and Appearance).
      Previously, we already referred to these tabs except for Font and Text.

Font is the tab you use to configure the writing font, size, 
colour and alignment.
You can also define a margin depending on the alignment of 
the text.

Text is the tab you use to insert writing into your badge
model.



1.2.3.1  Adding Concatenated Text

Concatenated text is an item designed to bring two strings of Text end to end, including a space while
avoiding any overlapping between data.

E.g.: Name [space] First name.

To add concatenated text, click on the button            and a text zone will appear in the list of components 
at the bottom left. In the same way as for adding an image, it can be moved around.

Concatenated text works in the same way as simple text. However, the purpose of concatenated text is to 
preserve two text zones side-by-side, positioning them to avoid any character overlaps.

You can also manage the size and rising font of the text zones individually. However, the writing size 
should not be set in the «auto» mode. 
By default, Text1 and Text2 are fields inheriting the Text zone adjustment.

You will obtain this visual
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1.2.4  Adding Photos

To insert a Photo into a badge model, click on the button 
This will display a geometrical shape on your model symbolizing a person.

To modify the image, go to the item en-
titled Selection Properties at the top left 
of the screen.

There are three tabs available
(Positioning, Photo and Appearance).

The Positioning and Appearance tabs are 
identical to what was seen previously.
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To insert a new Photo, in the section Import a New Photo. You have two options :

From an Image file:

Click on the button,             then browse through your storage 
space to insert your file (extensions supported include: jpg, 
jpeg, bmp, png ...). 
Validate by clicking on Open to gain access to additional
adjustments (brightness, contrast, cropping).

From a Webcam :

Click on the button,             then capture the image 
from the WebCam. The window opens giving you 
the possibility of selecting the capture zone and 
making adjustments (brightness, contrast,
cropping etc.).

1.2.5  Adding shapes

1.2.5.1  Ellipse

To add an Ellipse, click on the button

A circle appears on your badge model. By 
dragging the mouse over the edges of the 
circle, a double arrow appears, enabling 
you to draw out or reduce your circle.

To configure the frame, move to the title Selection Properties. You will see the Positioning and
Appearance tabs again, offering the same features as previously.



The Border tab enables you to set up the colour. There is a 
gauge for enlarging or reducing the thickness of the border. 

If you define a background colour in the 
appearance tab, the Border box will enable you
to hide the contour of the ellipse.

If you want to place your ellipse behind a photo, drag your mouse cursor over the «Ellipse» item in the «List 
of items». Then drag the item to the bottom under the «Photo» item.
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1.2.5.2  Line

Use this button to place a line on your badge model 

To change the colour, go to Selection Pro-
perties and select the Appearance tab.

The line can be extended and dragged out in both directions.

1.2.5.3  Rectangle

To add a rectangle to your badge model, click on the button              and a rectangle will be added to your 
badge model.
The Positioning and Appearance tabs are similar to any other item.

The Border tab used here enables you to adjust the radius of 
the corners, the thickness of the contour and to define the
colour. As seen previously for the ellipse, the Bordure (border) 
box enables you to hide the contour if you want to show only 
the colour background defined in the Appearance tab.



Creating a Badge Model 10

© 2017 - System I-Color - All rights reserved

If you want to put your text in a rectangle, move the mouse cursor over the «Text» item of the List of items. 
Then drag the item downwards under the «Rectangle» item. The Text item should be offset with respect to 
the rectangle item in the list of items.

1.2.6  Adding a QR Code

For your information, the QR Code is a type of barcode in two dimensions, comprising black modules in a 
square with a white background. The layout of these points defines the information contained in the code.

The content of the code can be decoded quickly after being read by a barcode reader, a mobile phone, a 
smart phone or a WebCam.
Its advantage is that it can store more information than a barcode, and above all, the data recognized 
directly by the applications to easily trigger actions like :

• Visiting a website.
• Connecting to a WiFi terminal.
• Making a call to a phone number or sending an SMS.
• Sending an email.
• Adding a virtual business card.
• Displaying text.

To add this functional feature, click on the button

Under the title Selection Properties at the top left, you will see 3 tabs (Positioning, Text and 
Appearance). In the same way as before, the positioning and size of the QR Code can be modified.
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We will use two tabs for configuring the QR Code :

The Text tab will be used for the input of data retranscribed in 
the QR Code. It will be generated automatically according to 
the information
inserted into the text field.

The Appearance tab will be used for colouring the background fill and the generated code.

1.2.7  Adding a barcode

To add a barcode, click on the button               and a barcode will be generated on your badge model.

Under the title Selection Properties at the top left, you will see 3 tabs (Positioning, Appearance and 
Barcode). In the same way as before, the positioning and appearance can be modified.
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The Barcode tab will be used to modify the barcode 
information.

The Type of code can be selected from the pop-up 
menu.
The Size defines its proportion. 
The Display box shows the code included in the value 
field on the badge model.

In most cases, the barcode is placed on the front of the badge. To do this, put your cursor in the 
«List of items» zone and click on Front. Then enter your barcode.
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2. Print configuration

As soon as your badge model is complete, you simply need to print it.
Configuration is set up using the software menu toolbar at the top left of the modelling window.

• Click on Print then on Configuration via the pop up menu.
• In the opening window, select your printer from the pop-up list.

• The button            gives you access to the printer driver configuration once you have selected it.
• The Automatic Orientation (Portrait/Landscape) box will not take the print orientation defined in the 

driver into consideration. iColor will print the badge automatically as shown in the visual image.
• The Ignore Paper Format box will not take the setting up of the driver into consideration either.
      If you check this box, the paper format will be managed by the software.
• The Manual Back-Front Printing box will first print the back of the badge then wait for you to put the 

badge back in the printer loader to start printing the front.
• The Rotation (180°) box will rotate the back and/or front of the badge through 180°.

The printer is now set up with the iColor software.
Print your badge using the keyboard shortcut «Ctrl + P» or use the Print Menu at the top left and click on 
Print.
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3. Tips

Description
Grid
Save

Zoom out
Zoom in
Refresh

Print
Display front
Display back
Unselect all

Quit

Raccourci
Ctrl + G
Ctrl + S

Ctrl + Keypad -
Ctrl + Keypad +

F5
Ctrl + P
Ctrl + 1
Ctrl + 2
Ctrl + D
Ctrl + Q

......

......

......

......

......

......

......

......

......

......

To quickly delete an item added by mistake
• Select the item in question and press the Delete key.
• You can also open the List of Items Menu and right-click on the item and then click on Delete.

Displaying a grid
• Click on the button  
• You can also use the keyboard shortcut «Ctrl + G».

Creating a Preview
• Go to the File menu toolbar click on Create a preview in the pop-up menu.
• When the window opens, choose where you will be saving the image.
• In the Filename field, remove the star and name your preview.
• Then finally, click on Save.

Preview Visual

Tips 14
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4. Glossary

4.1  Description of action buttons

Text button

Concatenated text button
(succession of 2 texts in the same text field)

Barcode button

Magnetic encoding button

MIFARE encoding button

Sphere creation button

Line creation button

Rectangle creation button

Photo addition button

Image addition button

QR Code addition button

Badge colour background additional button

Grid display button

Zoom out button

Zoom in button
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4.2  Description of Various Colour Panels

Samples
Defined colour panel 

Tint Saturation Value
HSV colour management system
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Value Saturation Light
HSL colour management system

Colour code (Red Green Blue)
RGB colour management system
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Four colour printing (Printer colour code: “Cyan”, “Magenta”, “Yellow”, (Key[Black]”)
Four colour management system
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4.3  Modeller Menu Toolbar Description

The Menu toolbar is split into 5 parts.

The File Menu is used to : 

 -   Create a New Badge
 -   Save the Badge
 -   Modify the Format 
 -   Create a Preview
 -   Print a Preview
 -   Quit the software

By clicking on Format you are taken to
this window.

The Print Menu is used to print and to set up your printer.

The Edit Menu is used to : 

 -   Delete the Model
 -   Delete the Front
 -   Delete the Back
 -   Unselect all
 -   Configure the Grid

Using the horizontal scrollbar, you can 
adjust the spacing of the Grid.

The Display Menu is used to : 

 -   Display the Front
 -   Display the Back
 -   Change the Zoom 
 -   Change the Value unit being used
 -   Display the Grid
 -   Refresh

The units proposed are the 
dot, mm, cm, inch, pt, pixel.

The grid is used for better laying out
the items on the badge.

The «?» Menu tells you about the version, the product key as well as the Software activation key.
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4.4  I-Color Opening Menu Toolbar Description

The Menu toolbar is split into 4 parts. 

The Edit Menu is used to :

 -   Create a New Badge Model.
 -   Modify the selected badge model (equivalent to opening the selected badge model).
 -   Duplicate the selected badge model.
 -   Rename the selected badge model.
 -   Delete the selected badge model.

The Print Menu is used to : 

 -  Print and/or Encode a Badge
 -  Configure for printing
 -  Print a Badge
 -  Print on the Front of the Badge
 -  Print on the Back of the Badge

The File Menu is used to Quit I-Color.

The «?» Menu tells you about the version, the product key and the activation key of the Software.
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4.5  I-Color upgrading

Basic Version

•  Handles multiple print jobs
•  Magnetic track encoding
•  Contactless encoding

Standard Version

•  Secure connection to iColor
•  Use of data from Excel files

Professional Version

•  Microsoft Access data management
•  Built-in table generator

Business Version

•  Microsoft SQL server data management
•  Oracle SQL data management
•  Built-in table generator 
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